Supported Development Environments

o Eclipse 3.4 (Ganymede) or 3.5 (Galileo)

■ Note: Eclipse 3.3 has not been fully tested with ADT 0.9.3 and support can no longer be guaranteed. We suggest you upgrade to Eclipse 3.4 or 3.5.

■ Recommended Eclipse IDE packages: Eclipse IDE for Java EE Developers, Eclipse IDE for Java Developers, Eclipse for RCP/Plug-in Developers

■ Eclipse JDT plugin (included in most Eclipse IDE packages)

■ Eclipse Classic IDE package is not supported. o JDK 5 or JDK 6 (JRE alone is not sufficient)

o Android Development Tools plugin (optional) o Not compatible with Gnu Compiler for Java (gcj)

• Other development environments or IDEs o JDK 5 or JDK 6 (JRE alone is not sufficient)

o Apache Ant 1.6.5 or later for Linux and Mac, 1.7 or later for Windows o Not compatible with Gnu Compiler for Java (gcj)

Note: If JDK is already installed on your development computer, please take a moment to make sure that it meets the version requirements listed above. In particular, note that some Linux distributions may include JDK 1.4 or Gnu Compiler for Java, both of which are not supported for Android development.

0 0

Post a comment